[PCC][PROBLEMES VIDEO] Le bug des Vidéos Coupées en Bandes

Pour tout sujet relatif au jeu Grandia 2 : informations, aide, problèmes d'installation ou de configuration, etc...
Répondre
Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

[PCC][PROBLEMES VIDEO] Le bug des Vidéos Coupées en Bandes

Message par Dark Magus » mer. 26 mars 2008, 18:40

Bonjour à toutes et à tous,

Lorsque vous jouez à Grandia 2, il se peut que les vidéos soient parfois coupées en plusieurs bandes.

Pour résoudre ce problème, il faut, avec un éditeur hexadécimal, éditer le fichier CONFIG.CFG, et à l'offset 0x00000050, remplacer 0x01 par 0x00.

Pour une raison inconnue, le jeu se comporte différemment selon que cette valeur soit à 0 ou à 1. De plus, une fois le jeu lancé, il remet cette valeur à 1 et l'enregistre dans le fichier de configuration, ce qui fait qu'il faudra répéter la manipulation à chaque fois avant de lancer le jeu.

Plus simplement, on peut se contenter de de supprimer CONFIG.CFG et de relancer GmConfig.exe pour configurer le jeu (ceci à chaque fois que l'on veut lancer le jeu...).

Par ailleurs, afin de contourner ce problème, notre exécutable patché conserve la valeur présente dans le fichier de configuration, ainsi, si elle est à 0 dans le fichier de configuration, il ne sera pas nécessaire de le modifier / re-créer à chaque fois. Il faudra par contre s'assurer que, la première fois que l'on veut lancer le jeu, la valeur soit à 0, soit en modifiant le fichier en hexa, soit en le supprimant et en le recréant avec GmConfig, soit en exécutant notre version de remplacement de GmConfig, nommée G2Config (elle remet la valeur automatiquement à 0 si elle est à 1).
Modifié en dernier par Dark Magus le mer. 23 mars 2011, 15:18, modifié 1 fois.
I AM the Boss. A dictator ? Yes.

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » mar. 16 sept. 2008, 15:34

Après un peu plus de recherches, en examinant bien le code désassemblé du jeu, il semblerait que ce bug soit lié au choix du mode 16-bit ou 32-bit, et dépende de la carte graphique.

Vous pouvez donc également essayer, à titre de solution "expérimentale", de permuter entre les modes 16-bit et 32-bit.

Sachez que, de toutes façons, il y a "tromperie" sur le mode 32-bit, dans ce jeu. En effet, après examen du code désassemblé du jeu, j'ai constaté que tout le travail sous-jacent est de toutes façons exécuté en 16-bit, ainsi, configurer le jeu en 32-bit n'améliore en rien les graphismes.
I AM the Boss. A dictator ? Yes.

Répondre