[Résolu] plantage

Pour tout sujet relatif au jeu Grandia 2 : informations, aide, problèmes d'installation ou de configuration, etc...
kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

[Résolu] plantage

Message par kathy » mer. 25 nov. 2009, 19:38

bonjour ,

voila j'ai réinstallé grandia 2 sur mon pc qui est sous XP , le jeu démarre jusqu'au moment de jouer , j'avance et une fois que j'arrie au cone multicolore le jeu plante , une fenetre s'affiche disant que le jeu a planter , pouvez vous m'aidez svp??

merci

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » mer. 25 nov. 2009, 20:16

Bonjour,

Est-ce que c'est sur le jeu original en anglais ou avec notre traduction ?

Enfin je ne vois pas pourquoi je pose la question, à mon avis c'est le cas, et lors de l'installation le patcheur a planté avant la fin. Il faut désactiver tout antivirus avant d'installer le patch. Et si ça ne marche pas malgré tout, il faut extraire le contenu de https://www.grandia2fr.ovh/g2patch/Grandia2_Core2.zip dans le dossier du jeu.
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » mer. 25 nov. 2009, 23:47

oui j'ai installer votre patch pour la traduction , et quand il est arrivé a la fin de l'instalattion , il me met un message disant que le patch a rencontrer un probleme et doit fermer , quand je lance le jeu , il est traduit mais arriver a l'endroit de l'echelle PAF il plate

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » mer. 25 nov. 2009, 23:53

en désactivant l'antivirus ca n'avait pas marcher le patch planter , j'ai remplacer le dossier , et le patch a été mis correctement ,

merci beaucoup , voir mtn si le jeu plante pas XD

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » mer. 25 nov. 2009, 23:55

bon ben je viens de lancer le jeu , ben ya prob lol , votre page s'inscrit avc ubisoft , et aprés game arts , PAF ca plante et coupe le jeu direct

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » jeu. 26 nov. 2009, 00:06

Hmm, et en exécutant G2Config.exe avant de lancer le jeu ?
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » jeu. 26 nov. 2009, 00:58

je viens d'essayer tout les résolution proposer et ca plante avec toute :(

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » jeu. 26 nov. 2009, 03:53

Hmm, non non, ça doit marcher, pour ce problème, la solution est bien d'extraire le contenu de Grandia2_Core2.zip dans le dossier du jeu.

Le message d'erreur indique-t-il celà :
AppName: grandia2.fr.exe AppVer: 0.0.0.0 ModName: ntdll.dll
ModVer: 5.1.2600.5512 Offset: 0000100b

(oui, l'offset est ce qui m'intéresse dans ce cas)

Enfin, à mon avis il manque tout simplement des fichiers. Le contenu de l'archive ZIP s'ajoute à ce qui existe, il ne faut supprimer aucun fichier avant de l'extraire.
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » jeu. 26 nov. 2009, 14:05

nan moi il me met ca

AppName: grandia2.exe AppVer: 0.0.0.0 ModName: grandia2.exe
ModVer: 0.0.0.0 Offset: 000884b9

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » jeu. 26 nov. 2009, 15:06

Cet offset semble indiquer qu'il plante au moment de charger un son. J'ai pas mal trimé pour arriver à reproduire cette erreur.

Fonctionnement du jeu au démarrage :

Après la lecture de la vidéo Game Arts, le jeu charge l'index de tous les sons. Puis, il affiche le menu et charge les sons utilisés à ce moment. Il cherche d'abord les sons dans le dossier uvms du jeu. S'il ne trouve pas le son dans ce dossier, alors il va le chercher dans le dossier uvms du CD du jeu. Si le fichier son n'est pas trouvé, le jeu plante avec une erreur à l'offset 000884b9.

Causes possibles de l'absence du fichier :

Difficile à dire. Le patcheur fourni en effet quelques sons modifié (volume réduit dans ces sons car beaucoup trop élevé). Mais en aucun cas n'en supprime. Quand bien même le patcheur pourrait corrompre ces fichiers, ces même fichiers sont également inclus dans Grandia2_Core2, ainsi lors de l'extraction, il est certain qu'ils sont bien présents dans le dossier uvms. Bien sûr, ces fichiers viennent compléter ceux déjà présents, en aucun cas il ne faut supprimer le dossier uvms avant l'extraction. Pour le reste, cela dépend du contexte, à savoir, s'il s'agit d'une version légale du jeu et si l'installation a été fait de telle sorte que l'on puisse jouer sans CD.

Solutions possibles :

- Mettre le CD pour jouer
- Recopier le contenu des dossiers vms, uvms et visual du CD vers le dossier du jeu, cela permet de se passer complètement du CD, et éventuellement de réparer des fichiers sons corrompus
- Réinstaller le jeu et le patch, mais ne PAS extraire le dossier uvms de l'archive Grandia2_Core2.zip

C'est tout ce que je peux voir. De toutes façons, je suis formel sur ce point : il s'agit d'un ou plusieurs fichiers sons manquants ou corrompus dans le dossier uvms du jeu.

P.S : une remarque aussi, tu as mis une adresse hotmail dans ton profil, ces adresses posent problème lors de l'envoi des notifications par e-mail, donc il se peut que tu ne reçoive pas toutes les notifications...
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » jeu. 26 nov. 2009, 16:00

hum hum , bon j'ai trouver la source du probleme mdr , j'avais oublier que j'avais retirer le CD hier soir mdr , donc voila pkoi ca planter , le jeu marche impec , je te remercie enormement pour ton aide , et merci beaucoup pour la traduction c'est du bon boulo ^^par contre je remarque une chose lors des combat , quand je gagne et que la derniere fenetre s'affiche ca block et le jeu repart , pareil pour les attaque de magie , l'image se bloque , et repart une fois les degat causé , c'est bizarre

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » jeu. 26 nov. 2009, 19:59

lol, absence du CD, je n'osais pas affirmer que c'était ce problème là :lol:

Hmm, pour le problème de blocage, ça coincide peut être avec les latences du lecteur CD. He t'invite à copier les dossiers vms, uvms et visual du CD vers le dossier du jeu (ça permettra de jouer sans CD).

Sinon je ne vois pas ce que c'est.
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » jeu. 26 nov. 2009, 21:20

erf je viens de planter , j'était en plein combat , et le nom des attaque été bizarre, et au moment ou j'ai lancer withe apocalypse avc elena le jeu a coupé , chui deg :(

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » jeu. 26 nov. 2009, 22:40

Bizarre c'est vague. Bizarre comment ?
I AM the Boss. A dictator ? Yes.

kathy
Joueur
Messages : 12
Enregistré le : mer. 25 nov. 2009, 19:37

Message par kathy » jeu. 26 nov. 2009, 23:35

nan ben c'est bon , j'ai copié les fichier du cd comme tu ma dit et mtn c impec ,ya pu de blocage , les grafik plus net , c impec merci a toi ^^

Répondre