[PCC]Windows 7 64 bit edition and video troubles

Pour tout sujet relatif au jeu Grandia 2 : informations, aide, problèmes d'installation ou de configuration, etc...
Répondre
Avatar du membre
doppiapunta
Leader of the Italian Translation
Messages : 8
Enregistré le : jeu. 11 janv. 2007, 02:25
Localisation : Italy

[PCC]Windows 7 64 bit edition and video troubles

Message par doppiapunta » lun. 03 janv. 2011, 23:29

Hi to you all guys.
This is Doppiapunta, a dear friend of our admin Dark MAgus and the leader of the italian translator team who is translating grandia 2 from english into italian.
Many of you are surely wonderin' the reasons of my topic.
Well..first of all excuse me if i'm wiritin' in english but I don't know french language so I'll try to exlain myself in this internatinal langauge. Then, my dear friend Magus will provide to translate all the details into French.

BTW... I was trying the beta version of Grandia 2 italian translation on my new pc with Windows 7 64 bit.

I did a clean installation of the game then i applied the patch.
Noerroros and no troubles untill after selecting NEW GAME I black screen instead the introoduction video.
Immeditaley I remebered a thread on this board speaking about the troubles related to Indeo video codecs and Windows Vista.
I thought It was the same.

So i downloaded codecs posted on the board and installed them as described in the post and then registered them with the reg file.

Nothing changed and I started lokkin' for the solution.

The trouble is that I have a 64 bit edition of Win 7 and, for this reason, several things are different.

1) So... first of all you have to go to this folder:

C:\Windows\SysWOW64

this is the new folder where the 64 bit edition sores its peculiar file ( in 32 bit versions it was SYSTEM32..remember?)

2) Look for the files called iccvid.dll and ir32_32.dll

You have to change the owner of the files in the advanced part in SECURITY tab properties that is set by the system as TRUSTEDInstaller and indicate your account as new owner.
After having dove it you have to set all the privilegies on the two files to the new user and remove all the priviligies from TrustedInstaller part.

Be care...it's quite delicate to do it.

After that you have to run a reg that will register the new position of the files.

4) open a notepad txt file and paste down these lines:

Code : Tout sélectionner


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"ir32_32.dll"="Indeo® video R3.2 by Intel"
"iccvid.dll"="Cinepak Codec by Radius Inc."

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.cvid"="iccvid.dll"
"vidc.iv31"="ir32_32.dll"
"vidc.iv32"="ir32_32.dll"


SAve the file as register.reg

5) run the register.reg to add the new information to the registry.


The explanation of all theese steps is simple: windows 7 holds the rights over codecs and you have to set the rights on your account.
Windows 7 64 bit edition has a new dedicated folder called SysWOW64 and files need to be copied inside of it.
More... the reg root for the 64 bit edition windows is different, so different is the region where to specify and register the dlls.


I hope my explanation was clear enough.

Bye Bye

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » mar. 04 janv. 2011, 13:08

Hi, thanks for this useful information, Diego. I'll translate that soon.
I AM the Boss. A dictator ? Yes.

Avatar du membre
doppiapunta
Leader of the Italian Translation
Messages : 8
Enregistré le : jeu. 11 janv. 2007, 02:25
Localisation : Italy

Message par doppiapunta » mer. 05 janv. 2011, 22:37

I modiefied the reg code in order to register also the other Indeo dlls...that is to say the ones specific for Indeo 4.1 and Indeo 5.o codecs.

here it is:

Code : Tout sélectionner


Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"ir32_32.dll"="Indeo® video R3.2 by Intel"
"ir41_32.dll"="Indeo® video R4.1 by Intel"
"ir50_32.dll"="Indeo® video R5.0 by Intel"
"iccvid.dll"="Cinepak Codec by Radius Inc."


[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv31"="ir32_32.dll"
"vidc.iv32"="ir32_32.dll"
"vidc.iv41"="ir41_32.dll"
"vidc.iv50"="ir50_32.dll"

Obiously before executing the reg file the dlls have to be in the "WINDOWS\SysWOW64" folder.

Bye Bye

Avatar du membre
k3nty
Joueur
Messages : 6
Enregistré le : mer. 23 févr. 2011, 15:17

Message par k3nty » mer. 23 févr. 2011, 15:25

Bonjour.

Je me permet de poster ici car je n'arrive pas à modifier le TRUSTEDinstaller.
En effet, quand je suis dans les propriétés du fichier iccvid.dll, aucune possibilité de modifier les droits de trustedinstaller.
Ce qui fait que quand je lance Grandia II patcher, retour windows.

Je suis sous Windows 7 32bit edition INTEGRAL.


Merci d'avance,
k3nty

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » mer. 23 févr. 2011, 17:04

Bonjour,

N'ayant jamais utilisé Windows 7 (toujours sur mon bon vieil XP), j'aurais hélas du mal à te répondre.

Y aurait-il un généreux utilisateur de Windows 7 dans le coin pour donner un coup de main ? ^^
I AM the Boss. A dictator ? Yes.

Avatar du membre
cloud
Graphiste
Messages : 177
Enregistré le : sam. 18 févr. 2006, 17:36

Message par cloud » mer. 23 févr. 2011, 20:37

J'ai Windows 7 Intégral aussi, j'avais installé Grandia 2 et le patch sur XP.
Là en le lançant directement depuis Seven, le jeu se lance sans soucis.

Si je lance le patcheur, il se lance, j'ai juste le message comme quoi Grandia 2 n'est pas installé.
As-tu essayé de faire "clique droit, exécuter en tant qu'admistrateur" ?

ou encore : " clique droit, Résoudre les problèmes de compatibilité" ?

Avatar du membre
k3nty
Joueur
Messages : 6
Enregistré le : mer. 23 févr. 2011, 15:17

Message par k3nty » mer. 23 févr. 2011, 22:51

Je rééssaye ça ce soir, je te dit ce qu'il en est.

Merci

Avatar du membre
k3nty
Joueur
Messages : 6
Enregistré le : mer. 23 févr. 2011, 15:17

Message par k3nty » jeu. 24 févr. 2011, 17:46

Je viens de tout réinstaller, et maintenant il fonctionne parfaitement.
Ca fait plaisir de pouvoir jouer à ce mythique en francais ! Merci !
Y'a juste le fait que pour quitter le jeu, je doit appuyer sur F12, mais rien de bien grave ! :D

Avatar du membre
Dark Magus
Programmeur
Messages : 1072
Enregistré le : ven. 02 déc. 2005, 19:21
Localisation : Toulouse
Contact :

Message par Dark Magus » ven. 25 févr. 2011, 06:09

Non ça c'est un bug du portage PC, le choix "Quitter" dans le menu ne fonctionne pas :p
I AM the Boss. A dictator ? Yes.

Avatar du membre
k3nty
Joueur
Messages : 6
Enregistré le : mer. 23 févr. 2011, 15:17

Message par k3nty » ven. 25 févr. 2011, 11:01

Il me semblait bien ^^

En tout cas la traduction, parfaite :)

Répondre